以 Eclipse 入门

作者 Nikolay Krasko
最近更新 2016-11-10


本教程通过创建一个Hello World程序的方式,给大家演示如何使用Eclipse编写Kotlin程序。

搭建开发环境

这里,我们假设Eclipse已经安装好了。如果没有,可以从下载页面下载。“Java开发者的Eclipse IDE”包。为正确运作,Eclipse Neon(4.6)或更新是必需的。

我们建议从Eclipse插件市场安装Kotlin插件。另一种选择是,复制这个按钮的链接到Eclipse窗口里面去运行:

image

通常情况下,我们使用Help-> Eclipse Marketplace…菜单,搜索Kotlin插件:

image

当然,你也可以使用一个传统的方式,使用一个网址来直接更新:

https://dl.bintray.com/jetbrains/kotlin/eclipse-plugin/last/

安装完成后需要重启Eclipse,重启后我们必须确定Kotlin插件正确安装。通过打开主菜单,看到Kotlin安装结果 Window -> Open Perspective -> Other...

image

创建一个工程

现在,我们可以创建一个Kotlin工程了。

选择File -> New -> Kotlin Project 继续进行。

image

创建好一个空项目之后,准备写基于Kotlin的JVM的代码(这种方式目前尚不支持JavaScript)。创建的项目,从Eclipse的角度来看,也是一个Java项目,但配置是基于Kotlin的,这意味着它有Kotlin构建器和Kotlin的运行时库引用。这个解决方案最大的好处就是,如果需要混合和Kotlin和Java代码,我们可以继续将Java类添加到项目中。

一个干净的Kotlin项目工程包浏览器,应该如下图所示:

image

现在,我们可以在src目录下,创建一个Kotlin文件了。

image

如果我们在创建文件的时候省略 “.kt” 文件后缀,Eclipse会自动帮我们添加上去。

image

在我们创建好Kotlin文件时候,我们就需要声明一个main函数作为程序入口。我们可以先输入一个“main”,在快速提示的时候按下“Enter”即可快速插入。

image

最后,我们需要书写一些代码打印可见消息,最常见的消息如:“Hello World”。

image

运行应用程序

最简单运行Kotlin应用程序的方式,就是在Kotlin代码上,点击鼠标右键,选择 Run As -> Kotlin Application

image

如果一切都正确的话,我们就可以在console窗口上看到输出结果。

image

现在,我们就完成了第一个在Eclipse上运行的Kotlin程序了。